Termination of PageBuilder Bundles Results in Rendering Failure

Incident Report for Arc XP

Resolved

We have fixed all of that the tokens that were active. If there are still issues, please redeploy your bundle.
Posted Oct 16, 2025 - 15:20 EDT

Update

We have identified that the bundle termination issue is limited to the termination of a *live* bundle. This is generally not advisable, but is currently possible via the API. We are adding additional guardrails to prevent this case. In the meantime, customers are advised to not terminate any live bundle, as this would invalidate their live token, which is used for content retrieval, and could thus negatively affect their site.

Beside this edge case, normal use of the PageBuilder deployer is now deemed safe, and normal operation can resume.

If you have any concerns, or experience any issue with the deployer, please open a new ticket
Posted Oct 16, 2025 - 14:41 EDT

Update

We rolled back the fix from this morning. Bundles can be deployed and promoted.

However Terminating a bundle can result in the incorrect deactivation of a live token.

We are still working on a permanent fix.
Posted Oct 16, 2025 - 12:58 EDT

Monitoring

A hotfix was released for the PageBuilder deployer, and normal activity can resume. However;

Any deployment made between 5am (US eastern time) and 8am (US eastern time) should be terminated and not used. Using bundles deployed during this time period will cause errors if promoted. Bundles deployed during this time window will need to be redeployed.
Posted Oct 16, 2025 - 07:58 EDT

Update

We haved determined that the issue may also be caused by any action taken in deployer and is not isolated only to the termination of bundles. While this issue is being investigated, please do not deploy, promote, or terminate any bundle.
Posted Oct 16, 2025 - 06:44 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 16, 2025 - 05:52 EDT

Investigating

We have identified an issue with the PageBuilder deployer. The issue is triggered when a bundle is terminated. Customers are advised to not terminate any bundle until the issue is fully resolved.

Terminating a bundle may result in the incorrect deactivation of a live token. If this happens rendering will begin failing. If this occurs to immediately resolve the issue, customers must re-deploy and re-promote the same bundle, as this will recreate the token. We are actively working on a fix for this issue to allow for termination of deployed bundles.
Posted Oct 16, 2025 - 05:51 EDT
This incident affected: Platform & Delivery Acceleration (PageBuilder Engine).