Pagebuilder UI and bundle deployment instability.

Incident Report for Arc XP

Resolved

An update to PageBuilder caused temporary instability in the PageBuilder UI sandbox environment and with bundle promotions in both sandbox and production environments. The issue has been mitigated, and all services are now operating normally.
Posted Aug 19, 2025 - 16:08 EDT

Investigating

Customers may experience issues viewing pages in Pagebuilder, or attempting deploys.
Posted Aug 19, 2025 - 12:39 EDT
This incident affected: Creator Apps (PageBuilder Editor).