Investigating Delayed Content Updates for Some Customers

Incident Report for Arc XP

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 18:58 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2026 - 18:50 EDT

Update

Implementation has shown early signs of successful resolution for some sites. Work continues to implement the full solution to all impacted areas.
Posted Jul 09, 2026 - 18:41 EDT

Update

Work is continuing on implementing a solution for this issue.
Posted Jul 09, 2026 - 18:23 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 09, 2026 - 18:01 EDT

Update

We are continuing to investigate the issue and will provide additional updates as more information becomes available.
Posted Jul 09, 2026 - 17:42 EDT

Investigating

We are investigating an issue affecting a limited number of customers, which is causing delays in content updates being reflected on the CDN. Our team is actively working to identify the root cause. We will provide updates as more information becomes available.
Posted Jul 09, 2026 - 17:11 EDT
This incident affected: Platform & Delivery Acceleration (Web Delivery).