Investigating Certificate Related Issues

Incident Report for Arc XP

Resolved

Impact was on a limited set of domain names that were incorrectly pointed to Arc DNS. Arc has proactively reached out to the impacted customers.
Posted Jan 13, 2026 - 13:30 EST

Identified

We’ve identified the source of the issue and are actively implementing mitigation measures.
Posted Jan 13, 2026 - 13:00 EST

Investigating

We are currently investigating a certificate-related issue that may be affecting Arc customer sites in some regions. Our team is actively working to identify and resolve the problem.
Posted Jan 13, 2026 - 12:26 EST
This incident affected: Platform & Delivery Acceleration (Web Delivery).