Delivery App unavailable

Incident Report for Arc XP

Resolved

This incident is resolved.
Posted Jul 30, 2025 - 10:50 EDT

Identified

We are currently experiencing an issue affecting the Delivery app. User-facing websites remain fully operational and are not impacted.

Our team is actively investigating and working to restore full access.
Posted Jul 30, 2025 - 10:10 EDT
This incident affected: Platform & Delivery Acceleration (Web Delivery).