Issue with fonts and images not loading after deploying bundles.

Incident Report for Arc XP

Postmortem

Customer Impact

On Monday, April 28th at 11:08 ET, clients reported that fonts and images were not loading correctly after deploying new bundles. The issue blocked production deployments and affected visual rendering of their sites.

Root Cause

The issue stemmed from a recent change in the Arc Docker image used during the deployment process. The updated image failed to append required version query parameters to CSS asset references during transpilation. As a result, new bundles were deployed without properly versioned URLs for fonts and images, leading to broken styling and assets.

Timeline

All times ET + 24 hour clock

Time Event
11:08 Clients raised initial support request due to fonts and images not loading.
11:42 Issue identified as related to recent changes in the deployment process.
12:37 Multiple clients reported similar issues with CSS/image asset loading.
14:37 Root cause confirmed; issue resolved by reverting the recent Docker change.
15:20 All affected clients were notified of the fix and advised to redeploy.
15:57 Clients confirmed that assets were loading correctly with proper versioned URLs.

Arc Next Steps

  • Engineering reverted the faulty change in the Docker-based transpilation logic.
  • Asset processing was corrected to ensure proper version tokens are applied to all CSS references.
  • Clients were instructed to rebuild and redeploy their bundles to resolve the issue.
  • Monitoring was enabled to track further anomalies and confirm resolution.
Posted May 06, 2025 - 12:44 EDT

Resolved

This incident has been resolved.
Posted Apr 28, 2025 - 18:11 EDT

Monitoring

A fix has been implemented and we are monitoring the results. Please redeploy your bundles and validate the outcomes.
Posted Apr 28, 2025 - 15:54 EDT

Identified

This will impact all clients who build with new API that was released this morning in Prod and Sandbox environments. We are in the process of reverting the code.
Posted Apr 28, 2025 - 15:32 EDT
This incident affected: Platform & Delivery Acceleration (PageBuilder Engine).