Rate Exceeded messages on web pages

Incident Report for Arc XP

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 17:22 EDT

Monitoring

A rollback was implemented at 3:58 EDT. Monitoring continues.
Posted Mar 25, 2025 - 16:51 EDT

Identified

This issue was identified as a response to unusual traffic patterns affecting the platform. A targeted rate limit that impacted a sub-set of customers was applied to maintain stability and prevent further disruption.
Posted Mar 25, 2025 - 16:44 EDT

Investigating

We are investigating reports of "Rate Exceeded" errors on web pages. Status updates to follow as developments are processed.
Posted Mar 25, 2025 - 16:26 EDT
This incident affected: Platform & Delivery Acceleration (Web Delivery).