The issue has been fully resolved, with confirmation from our infrastructure provider that mitigation is complete. All services are now functioning as expected.
Posted Oct 29, 2025 - 02:06 EDT
Update
Arc XP services remain stable, and customers should continue to experience normal operation.
Our infrastructure provider has implemented additional mitigations, and we are continuing to observe steady performance across all systems. We will provide a final update once the provider confirms the issue has been fully resolved.
Posted Oct 28, 2025 - 22:10 EDT
Update
All Arc XP services are currently functioning normally, and customers should be able to use the platform without interruption. If you are still experiencing any issues, please submit a ticket through the usual support channels.
The infrastructure provider issue remains active, and we continue to monitor the situation closely. We will provide another update once it has been fully resolved.
Posted Oct 28, 2025 - 20:34 EDT
Update
All Arc XP services are currently operating normally, and customers should be able to use the platform as expected. If you continue to experience any issues, please open a ticket through the usual support channels.
The underlying infrastructure provider issue is still ongoing, and we are continuing to monitor its status. We will share another update once it has been fully resolved.
Posted Oct 28, 2025 - 19:09 EDT
Update
At this time, all services appear healthy and customers should be able to use Arc XP normally. If that is not the case, please open a ticket through the normal channels.
The infrastructure provider issue remains ongoing and we will continue to monitor. We will update again once the situation has been fully resolved on the infrastructure side.
Posted Oct 28, 2025 - 17:58 EDT
Monitoring
We are continuing to observe limited disruption within our cloud provider infrastructure, but we have been able to implement remediation measures. Availability is coming back to normal status. We will continue monitoring the situation and take additional actions as necessary to maintain service.
Posted Oct 28, 2025 - 17:00 EDT
Update
We are continuing to effectively mitigate the impact of the instability with our cloud provider. Further updates will be shared as soon as additional information is available.
Posted Oct 28, 2025 - 16:41 EDT
Update
Our engineering team remains actively engaged with our cloud provider. The situation remains unchanged, and we will continue to monitor and share updates as they become available.
Posted Oct 28, 2025 - 15:52 EDT
Update
Our engineering team continues to monitor the instability impacting our cloud provider. We are in regular contact with their operations team and will share further updates as soon as new information becomes available.
Posted Oct 28, 2025 - 15:26 EDT
Investigating
We are aware of increased instability impacting our cloud provider. Our engineering team is in contact with their operations team and continues to monitor the situation closely. Further updates will be posted as information becomes available.
Posted Oct 28, 2025 - 14:50 EDT
This incident affected: Content Platform (Publishing Platform).