Brief outage in AP-Northeast-1

Incident Report for Arc XP

Postmortem

Customer Impact

On Monday, January 27th, from 16:03 ET to 16:37 ET, some clients experienced increased 404 responses that resulted in blank spaces or content that could not be loaded in their websites.

Root Cause

On Monday, January 27th as 16:03 ET, a scheduled release to Sandbox impacted a Production configuration. The misconfiguration resulted in traffic being routed to the incorrect environment resulting in the content not to be found. Once the correct configuration was restored, traffic responses and system returned to its normal state.

Timeline

All times ET + 24 hour clock

Time Event
16:03 Sandbox deployment is started
16:24 Issue is reported by clients
16:34 Engineering team is alerted about the incident
16:34 Engineering team restores the correct configuration
16:38 System fully restored

Arc Next Steps

Automation will be created to avoid manual intervention when updating production configurations for Content API.

Extra monitoring will be added to alert on increases in failures for rendering.

Posted Feb 13, 2025 - 14:55 EST

Resolved

We have discovered the root cause. An error in a recent deploy of Content API caused a temporary disruption. It is fully recovered.
Posted Jan 27, 2025 - 17:07 EST

Monitoring

We saw that there was a brief outage in AP-Northeast-1. We are seeing the outage recovered. We are investigating the root cause.
Posted Jan 27, 2025 - 16:54 EST
This incident affected: Content Platform (Publishing Platform).