Issues being reported with Composer circulations

Incident Report for Arc XP

Postmortem

On Friday, February 14th, at 08:22 ET, clients reported that Circulations and the Primary Website field disappeared after publishing an article in Composer V2. This prevented users from saving stories, leading to disruptions in their publishing workflows.

Root Cause

On Friday, February 14th, at 08:22 ET, multiple users reported issues with stories failing to load properly. Key information, including the Primary Website and selected Circulations, was missing. Some users only discovered the issue when attempting to save their stories, which were blocked due to the missing required fields.

At 10:48 ET, the engineering team identified the root cause: a slow network response caused delays in retrieving origin. This delay triggered a race condition, preventing the Primary Website and circulations data from being properly loaded.

To resolve the issue, the Arc XP engineering team updated the front to properly wait for an initial API response before rendering story data. This ensured that all necessary metadata was available, even in cases of slower network requests. By 16:56 ET, users confirmed that the issue was fully resolved.

Timeline

All times ET + 24 hour clock

Time Event
08:22 Initial customer report
10:48 The root cause is identified and hotfix development begins.
15:21 The deployment of the hotfix commences.
16:27 The hotfix deployment is successfully completed.
16:56 Users have reported that the issue has been successfully resolved.

Arc Next Steps

The team will conduct a post-mortem analysis to identify opportunities for improving the resilience of the Settings API. Additionally, the engineering team will review the frontend infrastructure to address potential race conditions and implement safeguards to prevent similar issues in the future.

Posted Feb 25, 2025 - 11:34 EST

Resolved

We have identified the cause of the issue preventing stories from saving in Composer and have deployed a fix. This was a sporadic problem, and you should no longer experience it moving forward. Since this issue was difficult to test due to its random nature, please let us know if you encounter any problems after this update.
Posted Feb 14, 2025 - 17:10 EST

Update

The fix was deployed to Sandbox environments and we are currently working on releasing this to Production.
Posted Feb 14, 2025 - 16:13 EST

Update

We are currently testing and reviewing the fix, and we will deploy it to Production shortly.
Posted Feb 14, 2025 - 14:49 EST

Update

We are continuing to work on a fix for this issue
Posted Feb 14, 2025 - 13:15 EST

Update

We have identified an issue and are working on a fix.
Posted Feb 14, 2025 - 11:44 EST

Identified

Our investigation has determined that in some cases when the Composer v2 editor loads, the primary website will not be loaded correctly. In these cases, story and circulations may not save properly.

If you encounter this issue, reload the page to make sure that circulations are loaded properly before making edits.

If this issue persists, you may revert to Composer v1 where this issue does not exist.
Posted Feb 14, 2025 - 11:17 EST

Investigating

Some users are reporting that circulations are not being saved properly.
Posted Feb 14, 2025 - 10:22 EST
This incident affected: Creator Apps (Composer) and Content Platform (Publishing Platform).