Increased latency affecting Pagebuilder

Incident Report for Arc XP

Resolved

The earlier issue causing increased latency in PageBuilder has been resolved. Page loading, publishing, and related tools are now performing normally. We’ll continue to monitor to ensure system stability.
Posted Nov 13, 2025 - 12:31 EST

Update

We’re currently investigating increased latency impacting PageBuilder. This may cause delays when loading or publishing pages, or when accessing PageBuilder tools. Our team is actively working to identify the root cause and restore normal performance.
Posted Nov 13, 2025 - 12:29 EST

Investigating

We are currently investigating this issue.
Posted Nov 13, 2025 - 12:08 EST
This incident affected: Creator Apps (PageBuilder Editor).