Network issues within Composer

Incident Report for Arc XP

Postmortem

Customer Impact

On Wednesday, September 24, around 11:50 ET, users saw unexpected logouts and error messages while editing content, disrupting their work in the content editing interface.

Root Cause

An update was introduced to enhance user session validation. Some users experienced session interruptions resulting in errors. The new validation was disabled, restoring normal access while a a permanent fix gets developed.

Timeline

All times ET + 24 hour clock

Time Event
Sept. 23, 19:16 A new authentication feature was enabled as part of a planned rollout. Existing user sessions remained active to ensure continuity.
Sept. 24, 11:50 A customer reported unexpected behavior related to authentication.
Sept. 24, 12:26 As a precaution, the feature was modified to assess impact and isolate variables.
Sept. 24, 16:32 Additional reports were received from other customers experiencing similar issues in the content management interface.
Sept. 24, 18:32 Configuration values were adjusted to align with previous behavior and to support a potential rollback if necessary.
Sept. 25, 09:38 The feature was fully disabled and previous functionality restored, which resolved the issue for affected users.

Arc XP Next Steps

  • Continue investigating the root cause of session-related issues.
  • Explore enhancements to monitoring and logging to better detect and respond to authentication-related issues.
Posted Oct 29, 2025 - 08:41 EDT

Resolved

Roll back for all regions is complete!
Posted Sep 25, 2025 - 10:32 EDT

Monitoring

We are rolling back a change that pushed out US-EAST on Monday. All logged in Arc XP users may need to re-authenticate into Arc Home especially if they are seeing the error messages about network issues or being prompted to log back in.
Posted Sep 25, 2025 - 10:18 EDT
This incident affected: Creator Apps (Composer).