Deployer Shows 401 Error for ap-northeast-1

Incident Report for Arc XP

Postmortem

Customer Impact

On Sunday, June 15 at approximately 9:26 PM ET, customers in the ap-northeast-1 AWS region reported that they were unable to access the PageBuilder Deployer. This meant they couldn’t use the deployer interview to promote bundles to Arc environments, which disrupted their ability to deploy content.

Root Cause

The issue occurred because of a misconfiguration while fixing a separate problem. A key setting (the maestro SSM parameter) was updated in all AWS regions except ap-northeast-1. Because of that, Maestro was still using an outdated or invalid GitHub token in the affected region, which caused failures when trying to use PageBuilder Deployer. We’ve now updated the setting in ap-northeast-1 to match the other regions and are redeploying Maestra so the fix takes effect.

Timeline

All times ET + 24 hour clock

Time Event
21:26 Error reported in ap-northeast-1 when trying to access the Deployer. Other regions remain unaffected.
10:05 Identified root cause: incorrect GitHub token in Maestro for ap-northeast-1.
10:27 Sandbox environment restored after fixing the misconfigured token.
10:31 Production environment fixed with correct token.
10:35 Confirmed that customers can now access the Deployer successfully.

Arc XP Next Steps

We’re improving our deployment process to ensure configuration updates are applied consistently across all regions. We’re also adding automated checks to catch and prevent issues when settings aren’t in sync between regions.

Posted Jul 07, 2025 - 17:29 EDT

Resolved

Service has been restored for all environments in the region. This issue was caused by an issue with a token isolated to the ap-northeast-1 region, which has now been corrected.
Posted Jun 15, 2025 - 22:34 EDT

Investigating

Customers in the ap-northeast-1 region are currently unable to access deployer and are receiving a 401 error.
Posted Jun 15, 2025 - 22:08 EDT
This incident affected: Platform & Delivery Acceleration (PageBuilder Engine).