PageBuilder Deployer Issue for Clients with Secondary Orgs

Incident Report for Arc XP

Postmortem

Customer Impact

On Tuesday, January 14th, Pagebuilder Deployer 2.1 was released to customer sandbox environments in us-east-1. Affected customers were unable to deploy bundles in sandbox environments. The specifics of the impact as well as the root cause varied depending on the circumstances for each affected customer.

Root Cause

  1. Secondary Orgs: Some configuration updates to route customer secondary orgs were missed and resulted in the PageBuilder Deployer incorrectly loading the bundles and deployments for the primary org.
  2. Non-standard Environments: Some configuration updates to include non-standard environments including outboundfeeds and pbeditor were missed and resulted in the PageBuilder Deployer not being able to access Engine releases.
  3. Missing bundles from those Deployed: PageBuilder Deployer 2.1 changed the sorting for deployments and enforced the 20 bundle limit so environments with more than 20 concurrent deployments experienced an issue where new deployments were not visible in the list.
  4. Themes Bundles Not Deploying: PageBuilder Deployer 2.1 enforces the two Engine Version Availability policy, but Themes still allows deployment using older versions of Engine, which caused deployment errors in Theme Settings. The recommendation for those customers is to upgrade to Themes Version 2.4.1 or newer.
  5. Showing Only Old Uploaded Bundles: The stated retention policy for uploaded bundles is to keep the last 90 days for unused bundles. However, this retention policy was not enforced and allowed environments to store over 1K bundles. In this scenario, the bundles were loading too slowly and caused newer bundles to not load. The recommendation was to delete non-deployed bundles older than 90 days. We offered to delete these bundles for the customers.

Timeline

All times ET + 24 hour clock

Time Event
~9:30 Deploy Deployer 2.0
12:02 ACS begins receiving reports relating to PageBuilder Deployer in Sandbox
13:29 Arc Engineering team notified and begins investigation
~14:00 Update trident config to fix secondary orgs
15:55 All tickets resolved

Arc Next Steps

1./2. Configurations for secondary orgs and non-standard environments have been implemented.

  1. Missing deployments in the UI: We are updating the UI to sort from latest to oldest so if a customer has over 20 deployments then the oldest non-live deployments drop from the list
  2. Themes customers should update to a newer version of Themes.
  3. Showing Only Old Uploaded Bundles: Creating a script to delete non-deployed bundles older than 90 days.
Posted Jan 28, 2025 - 14:25 EST

Resolved

This incident has been resolved. The root cause was identified as a configuration issue with the Trident system affecting secondary orgs.
Posted Jan 14, 2025 - 15:55 EST

Update

We are currently implementing a fix and should have this resolved shortly.
Posted Jan 14, 2025 - 15:42 EST

Identified

We have identified the root cause of the ongoing issue and are actively working to resolve it.
Posted Jan 14, 2025 - 14:24 EST

Update

We are continuing to investigate this issue.
Posted Jan 14, 2025 - 13:53 EST

Investigating

We are currently investigating an issue affecting clients with secondary organizations who are experiencing problems with the PageBuilder Deployer. The issue may result in difficulty deploying content or changes within PageBuilder for these clients.

Our engineering team is actively working on identifying the root cause and resolving the issue. We will provide further updates as we learn more and work towards a solution.
Posted Jan 14, 2025 - 13:52 EST
This incident affected: Platform & Delivery Acceleration (PageBuilder Engine).