Investigating Latency

Incident Report for Arc XP

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 14:15 EDT

Identified

The problem has been identified and mitigated. We're waiting for changes to propagate to all clients.
Posted Oct 30, 2025 - 14:05 EDT

Investigating

We are currently investigating increased latency affecting Admin and API request paths. This may intermittently impact user tools and site rendering. We will provide an update as soon as we have more information.
Posted Oct 30, 2025 - 13:45 EDT
This incident affected: Content Platform (Publishing Platform, View API).