Issue loading unpublished images

Incident Report for Arc XP

Resolved

This incident has been resolved.
Posted Feb 27, 2025 - 19:36 EST

Monitoring

The fix has been successfully deployed across all regions, and customers should now experience normal functionality when loading unpublished images.
Posted Feb 27, 2025 - 19:21 EST

Identified

We are aware of an issue in the newly released Photo Center version 1.82 which affects unpublished image access when not logged in to your Arc XP interface. This results in a failure to load unpublished images when not logged in to the Arc XP platform, including print integrations and certain article previews that rely on them. There is no impact to the loading of published images.
We are also aware of an increase in latency for image loads in some situations for this release, and that issue has been resolved.
Posted Feb 27, 2025 - 18:34 EST
This incident affected: Creator Apps (Composer, Photo Center).